Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#901 closed defect (fixed)

automatic conversion of URLs to links broken

Reported by: ray Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

There's a functionality to convert URLs and email addresses to links while typing. This is broken by rev[484] / fix for #699

The problem is here, that the RegEx? which is supposed to distinguish between is to generic

Change History (2)

comment:1 Changed 11 years ago by ray

  • Resolution set to fixed
  • Status changed from new to closed

the above should mean: which is supposed to distinguish between IPs and dates

committed rev [634]

  • fixed issue
  • added config var xinha_config.convertUrlsToLinks default false (which is consistent for URLs, because these weren't converted before due to the bug and inconsistent for email addresses)

comment:2 Changed 11 years ago by gogo

In changeset:672 I have made the config default to true, my comment on the changeset shows why this should be so.

Note: See TracTickets for help on using tickets.