Opened 13 years ago

Closed 12 years ago

#63 closed defect (worksforme)

Multiple Undo- truncates the file

Reported by: clem Owned by: gogo
Priority: normal Milestone: Version 1.0
Component: Xinha Core Version: trunk
Severity: major Keywords: Undo
Cc:

Description

Using Xinha 6th March) in CMSimple on localhost EasyPHP1.7 I have just had a spectacular display of the undo bug. I was doing a series of undos (maybe 10 or so) using the button. I think I undid once too often, and at that point 'The Warrior Princess' truncated the file I was working on, and maybe inserted a chunk of text earlier in the file, and maybe (though it may have been me) saved the resulting garbage over the master file.

Whatever, the file was then sufficiently corrupt that I couldn't persuade CMSimple to bring up the editor. (The CMSimple is sensitive, and won't load any editor if it can't scan the content.htm file).

So what am I suggesting.
This needs to be ticketed.( Done- Now I have got through)
A check needs to be inserted to prevent Undo blowing its stack. (posssibly all that is needed is a simple counter.

Hope this observation is useful.

Change History (2)

comment:1 Changed 13 years ago by gogo

  • Milestone set to Version 1.0
  • Priority changed from high to normal
  • Severity changed from critical to major
  • Version set to trunk

comment:2 Changed 12 years ago by gogo

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce the problem on FFox or IE.

Closing worksforme, if you can reproduce feel free to reopen.

Note: See TracTickets for help on using tickets.