Opened 15 years ago

Closed 15 years ago

#309 closed defect (fixed)

width of format selectbox in toolbar keep growing at every new element selected since changeset 195

Reported by: mokhet Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version: trunk
Severity: normal Keywords: toolbar format
Cc:

Description

  • bug not present in changeset [194]
  • bug appears in changeset [195]
  • bug still active in changest [204]

to view it :

  • start the full_example.html
  • click on one of the LI element in the text edition
  • click on the P element above the UL
  • the format selectbox width is increased
  • click on one of the LI element in the text edition
  • the format selectbox width is increased
  • and so on, the width keep increase at every refresh

copy the htmlarea.css changeset [194] to [195] and the bug disappear. And since changeset [195] only update the file htmlarea.css from

.htmlarea .toolbar select { font: 11px Tahoma,Verdana,sans-serif; }

to

.htmlarea .toolbar select, .htmlarea .toolbar option { font: 11px Tahoma,Verdana,sans-serif; height: 18px;}

it seems quite obvious the bug has been introduced somewhere in the above line but i dont really understand why :p

can be reproduced since changeset [195] with IE6, moz 1.7.3 (win) and FF 1.04 (win and linux)

Attachments (1)

formatselect_194_195.png (14.7 KB) - added by mokhet 15 years ago.

Download all attachments as: .zip

Change History (3)

Changed 15 years ago by mokhet

comment:1 Changed 15 years ago by mokhet

this bug is also appearing when switching from WYSIWYG to textmode to WYSIWYS, etc.

comment:2 Changed 15 years ago by gocher

  • Resolution set to fixed
  • Status changed from new to closed

it's the height: 18px;

Note: See TracTickets for help on using tickets.