Opened 13 years ago

Closed 11 years ago

#3 closed defect (fixed)

Horizontal Rule Selection

Reported by: gogo Owned by: gogo
Priority: normal Milestone: 2.0
Component: Xinha Core Version: trunk
Severity: normal Keywords: horizontal rule
Cc:

Description (last modified by gogo)

Need a way to reliabilty work with <hr> in the editor. My current thought is that we could use a transparent gif in place of <hr>? Anybody got better ideas?

To see the problem, use the Example, insert a horizontal rule and try working with it.

I have submitted a bugzilla report about this.

Attachments (3)

horizontal-rule.js (3.2 KB) - added by wymsy 12 years ago.
edit_horizontal_rule.html (5.8 KB) - added by wymsy 12 years ago.
HorizontalRule.zip (5.5 KB) - added by wymsy 12 years ago.
HorizontalRules? plugin

Download all attachments as: .zip

Change History (16)

comment:1 Changed 12 years ago by anonymous

How about an empty div with a border?

<div style="border-top:1px solid green;" />

comment:2 Changed 12 years ago by gogo

  • Description modified (diff)

The problem is that you can't "click on" the line to select it (and move/delete it) as you would expect to be able to. A bordered-div won't help with that.

comment:3 Changed 12 years ago by niko

can this be fixed by xinha?

comment:4 Changed 12 years ago by gogo

  • Version changed from 0.1 to trunk

We can't fix the hr problem itself, but I think we could make something SIMILAR by using an image or something.

It's really a big PITA because if mozilla would just fix the problem thier end it wouldn't be a problem.

Changed 12 years ago by wymsy

Changed 12 years ago by wymsy

comment:5 Changed 12 years ago by wymsy

I have written a HorizontalRule? plugin that does not exhibit this problem. It lets you set the width, alignment, height, color and shading attributes, and I have had no problem selecting existing hr's for editing or deleting. I'm attaching the key files, sorry, I haven't had time to zip up a package.

comment:6 Changed 12 years ago by anonymous

OK, here's the package in a zip file. Use this file, the earlier edit_horizontal_rule.html might have a small problem.

Changed 12 years ago by wymsy

comment:7 Changed 12 years ago by gogo

Thanks wymsy, your plugin is good and will be included. However it doesn't solve the problem. The problem is exhibited in Gecko, simply it is not possible to "click on" the <hr> to select it in the same way you would select for instance an image, they also have trouble with backspacing "over" them.

See the bugzilla report about this.

PS: If you'd like committ access to the subversion, let me know - james@…

comment:8 Changed 12 years ago by anonymous

OK, I see your point. It's not a 100% solution in that you don't get resizing handles and you can't drag and drop, but it does provide a workaround. What I am seeing with my plugin is that I can select a rule with a double-click and delete it or edit its attributes in the popup, and I can also backspace over it to delete it. I have tested in Firefox 1.0 on Mac OS X, and Firefox 1.0.4 on Win 2k. So it's a bit different from IE, where a single click works, but otherwise everything works and you can achieve the desired end result.

comment:9 Changed 12 years ago by wymsy

Checked in in changeset 347.

imho, we shouldn't hack xinha to compensate for a missing feature in Gecko. This plugin provides a very usable workaround, and from the user's standpoint provides the needed editing functionality.

comment:10 Changed 11 years ago by wymsy

  • Resolution set to wontfix
  • Status changed from new to closed

In the interest of getting xinha 1.0 released, and because nobody else has commented on this in a year, I am closing this. If anyone disagrees, feel free to reopen.

comment:11 Changed 11 years ago by anonymous

  • Milestone changed from Version 1.0 to 2.0
  • Resolution wontfix deleted
  • Severity changed from major to normal
  • Status changed from closed to reopened

I'm gonna reopen it, but I think it can be pushed back to 2.0, I don't think it's worth holding back 1.0 for it either, but is something we need to figure a way around sometime.

comment:12 Changed 11 years ago by gogo

anonymous == gogo :-)

comment:13 Changed 11 years ago by ray

  • Resolution set to fixed
  • Status changed from reopened to closed

rev [716]: I think this quite simple solution does fix this issue sufficiently

Note: See TracTickets for help on using tickets.