Opened 15 years ago

Closed 12 years ago

#295 closed defect (duplicate)

Investigate Link Issues (relative<->absolute conversions, stripBase)

Reported by: niko Owned by: gogo
Priority: normal Milestone: Version 1.0
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

do we really need fixRelatvieLinks here?

@@ -4144,7 +4147,6 @@
   var nullRE = new RegExp('((href|src|background)=[\'"])/+', 'gi');
   html = html.replace(nullRE, '$1' + location.href.replace(/(https?:\/\/[^\/]*)\/.*/, '$1') + '/');

-  html = this.fixRelativeLinks(html);
   return html;
 }

Change History (8)

comment:1 Changed 14 years ago by gogo

  • Summary changed from inwardHtml: fixRelativeLinks needed? to Investigate Link Issues (relative<->absolute conversions)

We'll use this ticket for the investigations into the link rewriting issues.

comment:2 Changed 14 years ago by mike@…

  • Severity changed from trivial to normal

Dynamic Urls such as http://www.soundclick.com/util/getplayer.m3u?id=2790003&q=hi
are split after the "?" and "&" symbols so you get: {{{
<a href='http://www.soundclick.com/util/getplayer.m3u?id=' 2790003&q='hi'>my link text</a>}}}

in IE and:

<a href="http://www.soundclick.com/util/getplayer.m3u?id=" 2790003&q="hi">my link text</a> in Mozilla Firefox

comment:3 Changed 14 years ago by niko

i cannot reproduce this.
does it happen in the full_example too? or you you have some kind of special setup?

comment:4 Changed 14 years ago by mike@…

I've updated my xinha install and it doesn't happen now.

comment:5 Changed 14 years ago by gogo

#759 has an interesting point regarding this.

comment:6 Changed 13 years ago by gogo

comment:7 Changed 13 years ago by gogo

  • Summary changed from Investigate Link Issues (relative<->absolute conversions) to Investigate Link Issues (relative<->absolute conversions, stripBase)

comment:8 Changed 12 years ago by ray

  • Resolution set to duplicate
  • Status changed from new to closed

this ticket is very old and does not bring much insight. I will close this now and direct the attention to #759

Note: See TracTickets for help on using tickets.