Opened 15 years ago

Closed 14 years ago

#259 closed defect (fixed)

context menu not working in full-screen plugin in firefox 1.03

Reported by: edward.borland@… Owned by: gogo
Priority: high Milestone:
Component: Plugin_ContextMenu Version:
Severity: critical Keywords:
Cc:

Description

In MSIE, the context menu is clipped in half in both normal and full screen modes, so that only the top of the menu is visible. See screenshot below.

In Firefox 1.03 the context menu works in normal mode but not in full screen mode.

Attachments (1)

contect_menu_clipped.gif (2.5 KB) - added by edward.borland@… 15 years ago.
context menu clipped in MSIE normal/fullscreen modes

Download all attachments as: .zip

Change History (7)

Changed 15 years ago by edward.borland@…

context menu clipped in MSIE normal/fullscreen modes

comment:1 Changed 15 years ago by PoeuffF

  • Priority changed from normal to high
  • Severity changed from normal to critical

I've the same problem with ContextMenu?'s plugin. It works in normal mode, but in FullScreen? mode when i click on the right button nothing appear and the right click firefox's window doesn't appear too.

I don't know why, i'm searching..

comment:2 Changed 14 years ago by anonymous

It's a z-index battle:
in plugins/ContextMenu/menu.css, the z-index of the context menu is set to 1000
in plugins/FullScreen/full-screen.js, upon entering full-screen mode (maximize), the z-index of the 'fullscreen' is set to 9999.
Change 9999 to 999, and the context menu is shown as normal

comment:3 Changed 14 years ago by gocher

fix the problem with the context menu in full-screen plugin in firefox 1.03 with the info from Sat Jul 9 08:01:55 2005 in changeset 257

comment:4 Changed 14 years ago by gogo

If this is fixed you can close it gocher.

comment:5 Changed 14 years ago by gocher

but what is with
context menu clipped in MSIE normal/fullscreen modes

comment:6 Changed 14 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

I imagine this is fixed by the changes I committed a couple of days ago with regard problems in the context menu in standards mode, at least I don't see this issue. Somebody reopen if it's not.

Note: See TracTickets for help on using tickets.