Opened 15 years ago

Closed 14 years ago

#202 closed defect (fixed)

Immediately after loading examples-body page the insert-image fails

Reported by: anonymous Owned by: gogo
Priority: low Milestone: Version 1.0
Component: Xinha Core Version: trunk
Severity: minor Keywords: insertimage focus
Cc:

Description

Load the examples/full_example-body.html (not the frameset page) into IE6 browser.
If you then immediately try to add an image, when you click ok in the insert-image dialog you get a 'null' error.

I think its because the textarea didn't have focus to start, and the code is unable to find the newly added img tag.

Change History (4)

comment:1 Changed 15 years ago by gogo

  • Priority changed from normal to low
  • Severity changed from normal to minor

Yes, that would be correct, perhaps we should make the toolbar disabled until the editor is focused.

comment:2 Changed 15 years ago by gogo

  • Milestone set to Version 1.0
  • Version set to trunk

comment:3 Changed 15 years ago by gogo

As of changeset:161 the toolbar is not active until the editor is activated (focused), this should solve the problem mostly but I think it may still be tricky if the user clicks outside of the editor and then clicks the image button as the editor is still active at that point but not focused?

comment:4 Changed 14 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

I think this can be closed now (incidentally, just tested and even if you click out of ther editor insert image is working properly).

Note: See TracTickets for help on using tickets.