Opened 15 years ago

Closed 15 years ago

#175 closed defect (worksforme)

Slovenian translation does not work (nor all the others I've tried)

Reported by: mclion@… Owned by: niko
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords: language
Cc:

Description

When changing _editor_lang from en to "si" or "it" xinha does not load.

I get this in the javascript console:

"Error: uncaught exception: Permission denied to call method XMLHttpRequest.open"

Change History (5)

comment:1 Changed 15 years ago by niko

do you use a webserver or do you access xinha trough file:// ?

comment:2 Changed 15 years ago by mclion@…

I run it from the local web server. If the _editor_lang is "en" it works without errors.
Plugins active at that time:
'CharacterMap?',
'ContextMenu?',
'FullScreen?',
'SuperClean?',
'TableOperations?'

I tought that the error was because some plugin, but with more testing I now see where it is. I was calling it with the "replaceall" function. For now I'm using the array method but it is somewhere limited (we've got some catalogue cms application that displays 3-5 dynamic textareas at the time, depending on the fields the user chooses). The plugin that fails if the lang is not english and the replaceall function is called is "FullScreen?" (maybe some other too, I've tested it just with this)...

comment:3 Changed 15 years ago by gogo

  • Owner changed from gogo to niko

comment:4 Changed 15 years ago by niko

i chan't reproduce this, using full_example in italian it works for me.

comment:5 Changed 15 years ago by gogo

  • Resolution set to worksforme
  • Status changed from new to closed

if our I18n expert can't reproduce then I'm closing it as works :)

Note: See TracTickets for help on using tickets.