Opened 3 years ago

Closed 8 months ago

#1675 closed defect (duplicate)

Valid HTML is being swallowed by Xinha on Chrome and Firefox

Reported by: guest Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc:

Description

Hello there,

in attached file you will find an HTML document. This is valid HTML 4.01 strict as for https://validator.w3.org/

Steps to reproduce the bug:

You should see that all of the content below the marker have disappeared.

From my tests this seems related to "br" alone in the markup. If you replace/wrap every first-level "br" tag with "p" tags, issue doesn't show up.

Please notice that we use Xinha to preview HTML content that has been generated externally and not by Xinha itself.

Any help would be greatly apreciated.

All the best

Antonio

Attachments (1)

xinhaTestValidatorTicketXinha.html (11.8 KB) - added by guest 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by guest

comment:1 Changed 9 months ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

This is fixed by [1335] I believe both in FF and Chrome, it was due to #1226

comment:2 Changed 9 months ago by gogo

The fix in [1335] was rolled back in [1338], this bug is back again now unfortunately.

See #1226

comment:3 Changed 9 months ago by gogo

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 8 months ago by gogo

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.