Opened 15 years ago

Closed 14 years ago

#167 closed defect (fixed)

URL with encoded characters gets transformed to 8bit

Reported by: xinha22apr05.ofer.hadaso@… Owned by: gogo
Priority: high Milestone: Version 1.0
Component: Xinha Core Version: trunk
Severity: major Keywords: URL
Cc:

Description

When going back from source mode to WYSIWYG mode the "Good Link" becomes "Bad Link":

<p><a href="http://guides.co.il/wiki/index.php/%D7%A9%D7%A2%D7%95%D7%9F_%D7%A7%D7%99%D7%99%D7%A5">Good Link</a></p><p><a href="http://guides.co.il/wiki/index.php/שעון_קייץ">Bad Link</a></p>

It seems that the encoded characters in the URL are converted to 8bit and the URL then seems to be not in compliance with RFC 3986 section 2.4 (or at least it doesn't lead to the page on the server).

This bug was already in HTMLarea 3 (but not in HTMLarea 2).
I didn't get to test it on FireFox? (Xinha crashed it b4 I got to see anything).
HTMLarea 3 on FF didn't have this bug (all tests on WINXP)

Change History (4)

comment:1 Changed 15 years ago by niko

don't know if i'm right - but i think this transformation is done by the browser itself.

in IE i reproduced it, in FireFox? the links don't get changed.

comment:2 Changed 14 years ago by gogo

  • Milestone set to Version 1.0
  • Priority changed from normal to high
  • Severity changed from normal to blocker
  • Version set to trunk

comment:3 Changed 14 years ago by gogo

  • Severity changed from blocker to major

comment:4 Changed 14 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in changeset:261

Note: See TracTickets for help on using tickets.