Opened 6 years ago

Closed 3 weeks ago

#1597 closed defect (wontfix)

Safari 5.1.6 Webkit insertNodeAtSelection

Reported by: guest Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version: trunk
Severity: normal Keywords: safari webkit selection insertnodeatselection
Cc: ejucovy

Description

Within the WebKit?.js, the selection process for the object passed to insertNodeAtSelection at line 420 is always of node type DOCUMENT and not ELEMENT:

Xinha.prototype.getSelection = function()
{

return this._iframe.contentWindow.getSelection();

};

Therefore when switching on the node.NodeType? on line 430, none of the cases are met and the text is just deleted and not replaced with underlined text.

Change History (2)

comment:1 Changed 5 years ago by ejucovy

  • Cc ejucovy added

comment:2 Changed 3 weeks ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

No steps to reproduce, I can't figure out what the problem is being talked about, chrome also uses Webkit and I use chrome with Xinha all the time and havn't come across anything that sounds like this.

Closing wontfix.

Note: See TracTickets for help on using tickets.