Opened 7 years ago

Closed 7 years ago

#1558 closed task (fixed)

unsupported_plugins refers users to a closed Trac ticket

Reported by: ejucovy Owned by: ejucovy
Priority: normal Milestone: 0.97
Component: Website Version: trunk
Severity: minor Keywords:
Cc:

Description

When a user loads a plugin from the unsupported_plugins directory, the following Xinha.debugMsg is emitted:

'You are using the unsupported Xinha plugin '+pluginName+'. If you wish continued support, please see http://trac.xinha.org/ticket/1297'

That ticket was the original proposal and work-plan for deprecating some plugins and creating the unsupported_plugins system.

I think it would be better to create a wiki page to document this, and change the debugMsg to point to that new wiki page. Benefits:

  1. No information will be lost -- the wiki page can (and should) link to ticket #1297 for historical context.
  2. We can add new unsupported plugins to the list by filing new tickets for them, and adding those tickets to the wiki page. If we stick with the current link, we have to keep reopening or adding comments to ticket #1297, which is bad information design.
  3. We can add more general information about unsupported plugins whenever we want if it's a wiki page.
  4. The wiki page can include some information for contributers like: "If you want to continue support for one of these plugins, please file a new ticket. If you want to propose making a plugin unsupported, please file a new ticket."

Change History (3)

comment:1 Changed 7 years ago by ejucovy

  • Owner set to ejucovy
  • Status changed from new to assigned

On the wiki page, we should make a list of unsupported plugins. The list should be grouped by release -- "Unsupported plugins in 0.96", "Newly unsupported plugins in 0.97" and so on. Each plugin on the list should have a link to the ticket that tracked the proposal to make it unsupported.

comment:2 Changed 7 years ago by ejucovy

I made a wiki page with the information about unsupported plugins in general, and about the specific plugins that are unsupported:

http://trac.xinha.org/wiki/Documentation/UnsupportedPlugins

comment:3 Changed 7 years ago by ejucovy

  • Resolution set to fixed
  • Status changed from assigned to closed

I changed the links in the debug message to the wiki page, r1275.

Note: See TracTickets for help on using tickets.