Opened 13 years ago

Closed 11 years ago

#132 closed defect (invalid)

Inserting images and weird http://null error

Reported by: Rob Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

Browser: IE6

When I add an image with an absolute path like /test/image5.jpg and click OK, IE tries to load the image from http://null/test/image5.jpg

Tell me if you can't reproduce it, I'll do more tests then :)

Thanks, Rob

Change History (3)

comment:1 Changed 13 years ago by Rob

Ok, tried to fix it myself, no luck though. Seems like you've encountered that error alredy, since there is a regular expression that replaces http://null

comment:2 Changed 13 years ago by gogo

Yes, IE does it, presumadly the problem is that IE wants to make semi-absolute (ie href="/foo") links to be fully absolute (href="http://domain.com/foo") but because the iframe (Xinha) is created dynamically it has no domain. So IE uses null as the domain. Yay.

That said, I don't think you should be seeing the problem, as you say, there is a workaround in the code for it (see outwardHtml in htmlarea.js) and nobody else has the problem that I am aware of.

Can you post a URL where we can see the problem.

(also, make sure you're using the nightly)

comment:3 Changed 11 years ago by gogo

  • Resolution set to invalid
  • Status changed from new to closed

No response, closing.

Note: See TracTickets for help on using tickets.