Opened 13 years ago

Closed 11 years ago

#129 closed defect (wontfix)

unknown runtime error - from IE 6

Reported by: rchisholm@… Owned by: gogo
Priority: normal Milestone:
Component: Xinha Core Version:
Severity: normal Keywords:
Cc:

Description

line: 2048
char: 7

no further details

Attachments (2)

error.doc (89.0 KB) - added by rchisholm@… 13 years ago.
screenshot of error
.2 (0 bytes) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (14)

Changed 13 years ago by rchisholm@…

screenshot of error

comment:1 Changed 13 years ago by niko

  • Component changed from Plugin - Fullscreen to Xinha Core

i love people that create a .doc for a screenshot *g*

...can you reproduce this error?
try the page in FireFox?, does it work, what does the JavaScript?-Console say?

what version do you use?

comment:2 Changed 13 years ago by gogo

Not enough information in that screenshot to even say if it's a problem with Xinha, let alone where in Xinha.

Submitter first try in Firefox with the Javascript console open, that will give a better error message. Alternatively install the Microsoft Script Debugger which will help you to narrow the problem down.

comment:3 Changed 13 years ago by rchisholm@…

Firefox 1.0.1 - tends to crash when editing text - plus the interface is all whacked out, I'd send a screenshot, but I don't need Niko's self-righteous, passive-aggressive cheap shots. The error is the same everytime the page loads in IE.

Errors caught from Firefox js console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml :: setFocus :: line 638" data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://browser/content/browser.js :: delayedStartup :: line 695" data: no]

comment:4 Changed 13 years ago by rchisholm@…

have not been able to re-create above js errors so I wouldn't waste your time on them just yet. IE still does not function, Firefox still looks awful. I followed the newb guide to the letter. I'm taken a look at my_config.js. Both IE & Firefox fail to pass changes in the textarea onto the next php page for entry into the database. Will look into the PHP code presently. It worked once, but not since.

comment:5 Changed 13 years ago by rchisholm@…

using the ms debugger, line 2048 of htmlarea.js is:

this._statusBarTree.innerHTML = HTMLArea._lc("Path") + ": "; clear

comment:6 Changed 13 years ago by rchisholm@…

applied latest nightly-build this morning, IE error seems to have been fixed. Firefox still suffers from an inordinate amount of "grey space" in the menu area. The Back button issue seems alive and well, but I have not read into that issue, which may lie in the Gecko code and not be a Xinha issue.

comment:7 Changed 13 years ago by rchisholm@…

spoke too soon - error occurred when I began to edit text. This time on line 2047, turns out to be the same line though:

this._statusBarTree.innerHTML = HTMLArea._lc("Path") + ": "; clear

comment:8 Changed 13 years ago by anonymous

I'm using the latest version. It works fine on Firefox, but gives me "can't open the page" message on IE 6.

comment:9 Changed 13 years ago by gogo

rchisholm: Try removing the tabbrowser extention in FF and see if it helps.

comment:10 Changed 12 years ago by stevestorey@…

I've had this a lot with my home-rolled editor. This happens when you try to insert a block-tag inside a non-block tag using the innerHTML property. Making this more clear:

something.innerHTML="<span><div>something</div></span>";

isn't strictly allowed. IE6 sometimes complains about this, and sometimes doesn't (e.g. if you make it <span><p> It seems ok most of the time).

http://www.codingforums.com/archive/index.php/t-29380.html

says that SPAN inside a TD will do it. Practically, the only way to trap it is to validate the HTML before doing the innerHTML=....

Alternatively, it could go inside a try { } catch block, showing a messagebox error stating there's something wrong with the markup (slightly better than "Unknown runtime error" :) )

Steve.

Changed 12 years ago by anonymous

comment:11 Changed 12 years ago by anonymous

FUCK, I've been searching about this unknown error for a week. Finally I found that "insert a block-tag inside a non-block tag" not allowed... amazing, another Internet Explorer Secret! :)

Anyway, thank you for the answer!

comment:12 Changed 11 years ago by gogo

  • Resolution set to wontfix
  • Status changed from new to closed

Seems not really fixable.

Note: See TracTickets for help on using tickets.