Opened 9 years ago

Closed 9 years ago

#1225 closed enhancement (invalid)

adding videos

Reported by: guest Owned by: gogo
Priority: normal Milestone: 0.96
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc:

Description

I would like to add my own button for inserting video code (such as youtube code for videos) with this editor.

And I created icon, and copied code from InsertImage? module so my module is called InsertVideo?. And everything is ok, I get image with that window, but I would like to insert not a image, but a video. I realized that problem is in insert_image.js file (my version in this case is insert_video.js). And when I click "OK" on popup dialog after putting code in there in input tag, I manage to get that text into wanted window, but it is placed in attribute src of img tag. The problem is in file insert_image.js, because in that file it is declared how that img tag is created. But the code is too heavy me to handle and understand. Can someone put example not how img tag, but how div tag in that file can be created, alongside with some inner HTML (text in it)?

Change History (2)

comment:1 Changed 9 years ago by guest

Hello,
you could try going here http://www.jljsolutions.co.uk/xinha.html to see a plug-in I have developed. I don't think this will ever be committed to xinha so you'll have to install it manually but I've included some instructions,
John

comment:2 Changed 9 years ago by gogo

  • Resolution set to invalid
  • Status changed from new to closed

John's plugin would certainly be committed if you provide a clean patch which can be applied :)

But this is off topic for the bug tracker, try the forums.

Note: See TracTickets for help on using tickets.