Opened 12 years ago

Closed 12 years ago

#1169 closed defect (invalid)

Editor loads as a normal text area

Reported by: guest Owned by: gogo
Priority: normal Milestone: 0.96
Component: Xinha Core Version: trunk
Severity: normal Keywords:
Cc:

Description

Hello,

I have been at this all day but cannot figure out the problem the xinha editor will not load, I am testing it in internet explorer on a localhost. I have tried to debug it but no errors show up. Please see code below:

*HTML PAGE*
<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Untitled Document</title>

<script type="text/javascript">

_editor_url = "C:/wamp/www/SCS/scs_pages/xinha/"; (preferably absolute) URL (including trailing slash) where Xinha is installed
_editor_lang = "en";
And the language we need to use in the editor.

</script>
<script type="text/javascript" src="C:/wamp/www/SCS/scs_pages/xinha/XinhaCore.js"></script>
<script type="text/javascript" src="C:/wamp/www/SCS/scs_pages/xinha/my_config.js"></script>
</head>
<form name=WorkInstructions_Create method="post" action="WorkInstructions_Upload.php">

<h1 align="center"><strong>Create Procedure </strong></h1>
<table border="0">

<tr>

<td width="124">Purpose</td>
<td width="330"><input name="txtPurpose" type="text" id="txtPurpose" size="50"></td>

</tr>
<tr>

<td>Scope</td>
<td><input name="txtScope" type="text" id="txtScope" size="50"></td>

</tr>
<tr>

<td>Definitions</td>
<td><textarea name="txtDef" cols="50" rows="10" id="txtDef"></textarea></td>

</tr>
<tr>

<td>References</td>
<td><textarea name="txtRef" cols="50" rows="10" id="txtRef"></textarea></td>

</tr>
<tr>

<td>Procedure Name </td>
<td><input name="txtProcName" type="text" id="txtProcName" size="50"></td>

</tr>
<tr>

<td>Procedure Details </td>
<td>

<textarea id="txtProcDetID" name="txtProcDet" rows="10" cols="50" style="width: 100%"></textarea>

</td>

</tr>
<tr>

<td>&nbsp;</td>
<td><div align="center">

<input name="cmdSaveProc" type="submit" id="cmdSaveProc" value="Save Document">

</div></td>

</tr>

</table>
</html>

*myconfig.js*
xinha_editors = null;

xinha_init = null;
xinha_config = null;
xinha_plugins = null;

This contains the names of textareas we will make into Xinha editors
xinha_init = xinha_init ? xinha_init : function()
{

/ STEP 1 *

  • First, what are the plugins you will be using in the editors on this
  • page. List all the plugins you will need, even if not all the editors
  • will use all the plugins. *
  • The list of plugins below is a good starting point, but if you prefer
  • a must simpler editor to start with then you can use the following
  • xinha_plugins = xinha_plugins ? xinha_plugins : [ ]; *
  • which will load no extra plugins at all. /

xinha_plugins = xinha_plugins ? xinha_plugins :
[

'CharacterMap?',
'ContextMenu?',
'ListType?',
'SpellChecker?',
'Stylist',
'SuperClean?',
'TableOperations?'

];

THIS BIT OF JAVASCRIPT LOADS THE PLUGINS, NO TOUCHING
if(!Xinha.loadPlugins(xinha_plugins, xinha_init)) return;

/ STEP 2 *

  • Now, what are the names of the textareas you will be turning into
  • editors? /

xinha_editors = xinha_editors ? xinha_editors :
[

'txtProcDetID'

];

/ STEP 3 *

  • We create a default configuration to be used by all the editors.
  • If you wish to configure some of the editors differently this will be
  • done in step 5. *
  • If you want to modify the default config you might do something like this. *
  • xinha_config = new Xinha.Config();
  • xinha_config.width = '640px';
  • xinha_config.height = '420px'; * */

xinha_config = xinha_config ? xinha_config() : new Xinha.Config();

/ STEP 4 *

  • We first create editors for the textareas. *
  • You can do this in two ways, either *
  • xinha_editors = Xinha.makeEditors(xinha_editors, xinha_config, xinha_plugins); *
  • if you want all the editor objects to use the same set of plugins, OR; *
  • xinha_editors = Xinha.makeEditors(xinha_editors, xinha_config);
  • xinha_editorsmyTextArea?.registerPlugins(['Stylist','FullScreen?']);
  • xinha_editorsanotherOne?.registerPlugins(['CSS','SuperClean?']); *
  • if you want to use a different set of plugins for one or more of the
  • editors. /

xinha_editors = Xinha.makeEditors(xinha_editors, xinha_config, xinha_plugins);

/ STEP 5 *

  • If you want to change the configuration variables of any of the
  • editors, this is the place to do that, for example you might want to
  • change the width and height of one of the editors, like this... *
  • xinha_editors.myTextArea.config.width = '640px';
  • xinha_editors.myTextArea.config.height = '480px'; * /

/ STEP 6 *

  • Finally we "start" the editors, this turns the textareas into
  • Xinha editors. /

Xinha.startEditors(xinha_editors);

}

Xinha._addEvent(window,'load', xinha_init); this executes the xinha_init function on page load

and does not interfere with window.onload properties set by other scripts

Change History (2)

comment:1 Changed 12 years ago by guest

not a bug. use the forum or newbie guide!

comment:2 Changed 12 years ago by ray

  • Resolution set to invalid
  • Status changed from new to closed

right

Note: See TracTickets for help on using tickets.