Opened 12 years ago

Closed 11 years ago

#1164 closed defect (invalid)

Images directory defaults to demo images?

Reported by: guest Owned by:
Priority: normal Milestone: 0.95
Component: Plugins Version: trunk
Severity: minor Keywords: ExtendedFileManager ImageManager Images Directory
Cc:

Description

Xinha 0.95RC2 on Safari3 Mac OS X

I just installed the fresh 0.95RC2 and it all loos good.

But for some reason the images I see in ImageManager? (ExtendedFileManager?) is the demo images from xinha, and not my images...

Files works great (correct directory), but not my images.

Don't know if anything in the settings have to be changed (have not found any notes).

Including the backend data, that to me seems ok:

backend_data = {
'backend_data[data]': 'a:21:\x7Bs:17:\x22max_foldersize_mb\x22;i:0;s:9:\x22files_dir\x22;s:17:\x22../../../../files\x22;s:10:\x22images_dir\x22;s:18:\x22../../../../images\x22;s:9:\x22files_url\x22;s:14:\x22/survey/files/\x22;s:10:\x22images_url\x22;s:15:\x22/survey/images/\x22;s:20:\x22max_filesize_kb_link\x22;s:3:\x22max\x22;s:23:\x22allowed_link_extensions\x22;a:16:\x7Bi:0;s:3:\x22jpg\x22;i:1;s:3:\x22gif\x22;i:2;s:2:\x22js\x22;i:3;s:3:\x22pdf\x22;i:4;s:3:\x22zip\x22;i:5;s:3:\x22txt\x22;i:6;s:3:\x22psd\x22;i:7;s:3:\x22png\x22;i:8;s:4:\x22tiff\x22;i:9;s:3:\x22tif\x22;i:10;s:3:\x22eps\x22;i:11;s:4:\x22html\x22;i:12;s:3:\x22swf\x22;i:13;s:3:\x22xml\x22;i:14;s:3:\x22xls\x22;i:15;s:3:\x22mov\x22;\x7Ds:16:\x22thumbnail_prefix\x22;s:2:\x22t_\x22;s:13:\x22thumbnail_dir\x22;s:5:\x22thumb\x22;s:14:\x22resized_prefix\x22;s:8:\x22resized_\x22;s:11:\x22resized_dir\x22;s:0:\x22\x22;s:10:\x22tmp_prefix\x22;s:4:\x22_tmp\x22;s:21:\x22max_filesize_kb_image\x22;i:0;s:16:\x22allow_edit_image\x22;b:1;s:13:\x22allow_new_dir\x22;b:1;s:12:\x22allow_rename\x22;b:1;s:20:\x22allow_cut_copy_paste\x22;b:1;s:19:\x22images_enable_title\x22;b:1;s:19:\x22images_enable_align\x22;b:1;s:21:\x22images_enable_styling\x22;b:1;s:18:\x22link_enable_target\x22;b:1;\x7D',
'backend_data[session_name]': 'PHPSESSID',
'backend_data[key_location]': 'Xinha:BackendKey',
'backend_data[hash]': '525b68daab4115dfd356fb552c1e48cf9816297e',
PHPSESSID: 'faco8d1h6tg9il47sei2nak036'
};

Change History (8)

comment:1 Changed 12 years ago by guest

Did you upgrade to this version, or testing it on a test page?
--
Sina Salek

comment:2 follow-ups: Changed 12 years ago by guest

I actually meant you're using the same config or a fresh new one for testing it?
--
Sina Salek

comment:3 in reply to: ↑ 2 Changed 12 years ago by guest

Replying to guest:

I actually meant you're using the same config or a fresh new one for testing it?
--
Sina Salek

Hello Sina

No It's the same config, since I've not found any notes that it must be changed.

This is what my script passes to the backend:

$IMConfigfiles_dir? = $homepath."files";
$IMConfigfiles_url? = $preferencessiteroot?."files/";
$IMConfigimages_dir? = $homepath."images";
$IMConfigimages_url? = $preferencessiteroot?."images/";

The files directory is pointing correctly, but the images directory (for some unknown reason) is ignored and I'm working with the example images directory.

If both files and images would be malfunctioning, I'd say that it it something with the config file - but since it's only the images dir it feels more like a plugin error.

If anyone have a clue it would be great.

\Per H

comment:3 in reply to: ↑ 2 Changed 12 years ago by guest

Replying to guest:

I actually meant you're using the same config or a fresh new one for testing it?
--
Sina Salek

Hello Sina

No It's the same config, since I've not found any notes that it must be changed.

This is what my script passes to the backend:

$IMConfigfiles_dir? = $homepath."files";
$IMConfigfiles_url? = $preferencessiteroot?."files/";
$IMConfigimages_dir? = $homepath."images";
$IMConfigimages_url? = $preferencessiteroot?."images/";

The files directory is pointing correctly, but the images directory (for some unknown reason) is ignored and I'm working with the example images directory.

If both files and images would be malfunctioning, I'd say that it it something with the config file - but since it's only the images dir it feels more like a plugin error.

If anyone have a clue it would be great.

\Per H

comment:4 Changed 12 years ago by ray

  • Resolution set to worksforme
  • Status changed from new to closed

Sorry, I can't reproduce this.

comment:5 Changed 11 years ago by guest

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Nope, does still not work for me :-(

Either it's my settings or something strange (if it is the settings something has changes since 0.94 where it works).
I'll make an archive with my settings and a more detailed report soon.
\pH

comment:6 Changed 11 years ago by guest

  • Severity changed from major to minor

My fault!

After testing, fiddling, tweaking, tryníng to understand the JS...

Somewhere 'ImageManager?' has pop'ed into the loaded plugins, destroying tne EFM config

When I removed it it all works :-)

Sorry for the trouble

comment:7 Changed 11 years ago by ray

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.