Opened 16 years ago

Closed 14 years ago

#11 closed defect (fixed)

Change HTMLArea objects/namespace to Xinha

Reported by: gogo Owned by: gogo
Priority: normal Milestone: 2.0
Component: Xinha Core Version: trunk
Severity: minor Keywords:
Cc: mokhet@…


It wuld be nice to get rename the HTMLArea namespace/object(s) to Xinha.

Change History (4)

comment:1 Changed 16 years ago by mokhet

  • Cc mokhet@… added

if by this you mean get rid of all HTMLArea occurence in the code, i am 100% agree and i would be more than happy to help. This is xinha, htmlarea was nice but is dead. Long life xinha !

comment:2 Changed 15 years ago by gogo

  • Milestone set to 2.0
  • Version set to trunk

comment:3 Changed 14 years ago by ray

Xinha is now Xinha!
rev [649]:

  • Changed the namespace in all core files (list below)
  • Aliased HTMLArea = Xinha for backwards compatibility (in core and popup.js)
  • IMPORTANT: changed name of core file from htmlarea.js to XinhaCore?.js
    • created a copy of XinhaCore?.js by the name of htmlarea.js for backwards compatibility (will remove this in later releases)
  • changed name of htmlarea.css to Xinha.css
  • changed examples accordingly

This should be a backward compatible change and all plugins should keep working as they are, however they should (have to) be transitioned in the future

Changed files:

  • Xinha.js
  • htmlarea.js
  • dialog.js
  • examples/ext_example-body.html
  • examples/ext_example-menu.php
  • examples/simple_example.html
  • examples/testbed.html
  • functionsIE.js
  • functionsMozilla.js
  • getHTML.js
  • htmlarea.css
  • htmlarea.js
  • inline-dialog.js
  • panel-dialog.js
  • popups/about.html
  • popups/editor_help.html
  • popups/insert_image.html
  • popups/insert_image.js
  • popups/insert_table.html
  • popups/link.html
  • popups/link.js
  • popups/popup.js
  • popups/select_color.html

comment:4 Changed 14 years ago by gogo

  • Resolution set to fixed
  • Status changed from new to closed

May as well close this thanks to your good work Ray. I made a small change in changeset:659 - a better way of handling the backwards compat.

Note: See TracTickets for help on using tickets.